
Colorization II
and Hue and Eye...

Note:
Photoshop 2.5 and later addendum
This tip works very well in Photoshop 2.0. In PS 2.5 the HSB and HSL color spaces were eliminated. These
effects still can be produced in PS 2.5 with the HSB/HSL plug-in which is included with PS 2.5.1. This filter
will allow you to create the effects documented here but you will have to convert back to RGB to see them
properly. The HSB/HSL plug-in is difficult to work with due to the intermediate step of converting back to
RGB to view the results. This technique may be the reason you've been looking for to keep Photoshop 2.0
on your machine.

Why? 
Well, I didn’t get to finish the job in the first document and I’m not likely to do it with this one, either. There
are LOTS of ways to meddle with color. But I scratched the surface pretty well.

What?
Colorization is still the topic, meaning how to go from monochrome “grayscale” images to color. I assume
you have read the first chapter of this, if not, do it now. You wouldn’t read a murder mystery back to front
now, would you. (Chorus of the sickoes “Sure we would....” I knew it!)
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How?
I have started to throw in little bonus techniques on how to create textures ‘n stuff. Here is a One Minute
Quickie (with lots of variations to try):
1. Make the usual window, File > New,  400x by 300y 72 dpi  in grayscale
Select  Filter > Noise > Add Noise... and use 222,  “Uniform” to make it look like that:

Figure 1)  Uniform Noise at 222

2. Now go to Filter > Stylize > Diffuse...and click ok. Repeat that 10 times. (Obviously use Command-f, Ctrl-f
to repeat.)   A more structured stucco-like texture emerges. Use Filter > Blur > Blur More once.

Figure 2a)   After 10x Diffuse... Figure 2 b) ...and then  Blur More



This will be our starting texture, and while it now may look a bit like soft Granite (more so in a larger area
than this sample) there are lots of weird alternate styles hiding in there. I am just traversing the idea space in
one random way. To do more explorations from the resulting image, make a few copies via Image >
Calculate > Duplicate now. We’ll come back to them. (Is that a macro in your household yet?)

3. OK, lets jump into color a whole other way: Change the image from Mode > Grayscale to Mode > RGB,
nothing seemingly happens. Now, if you go back to the Mode menu you find that the bottom options “HSL”
and “HSB” are no longer greyed out.

4. Change from Mode > RGB to Mode > HSB now... Again nothing really happens, except the current win-
dow is redrawn and the title bar reads  “Untitled-1  (Brightness,  1:1)“  (by the way if that ever says some-
thing other than 1:1 you are zoomed in or out and are not seeing the real thing... Tiplet >>> Double click on
the magnifier tool to reset it. )   This indicates that you are seeing one channel, Brightness, which happens
to be the original Grayscale image, since that information is interpreted as the brightness during the conver-
sion.

5. We have added two other channels, though. To see one, use Mode > Channel  and the hierarchical menu
shows Hue, Saturation and Brightness (with their short cuts: command-1, 2 and 3...(Ctrl-1,2 and 3). Select
Saturation....
The window is redrawn, the title says Untitled, Saturation and everything is..... black.
“Nothingness! A void.” “What kind of a void?” “An empty void.” (Make a note to watch Love & Death)



6. This channel contains the information on color saturation, in other words “How MUCH color is there at any
one pixel location”. The way it works is that this is a 256 grays (8 bit) channel and White means FULL color
saturation, Black means NONE, greys anywhere in-between. In a converted Grayscale image there isn’t any
color to begin with, so initially the channel is black. But, the beauty is that you have all the tools of
Photoshop available to mess around with this channel all by itself and create the color information directly!
So, let’s do that. Use the Blend tool (Under the magnifier) click at the top area of the window and drag down
to the bottom (Tip > Use the shift key to constrain the movement to true vertical). You will get this:

Figure 3)   Creating a gradient in the Saturation channel

7. Switch to Mode > Channel > Hue where we have the same situation. Now a grayscale channel defining
WHICH color, pixel by pixel. Understand that these two work together! Defining a color here won’t show up
until there is a saturation other than black set in the Saturation channel!   Since there is no color after the
conversion from grayscale, this, too, is initially black. Let’s artificially create different hues here.

8. Blend tool, click upper left, drag down to lower right...:
Figure 4)  Creating a gradient in the Hue channel...



Ok to sum this up for a second and as  a mental pop-quiz: The brightness channel looks just like the origi-
nal grayscale image (in our case that granite texture, but you can use anything monochrome).

Think of the Saturation channel as : “where it is black, there won’t be any color at all, where it is bright white,
the color (defined in the Hue channel) will be at full intensity and greys fall in-between....”

Think of the Hue channel as: “where it is black there will be a certain color in the spectrum (‘red’, it turns out)
(with the intensity defined in the saturation channel), where it is white, it is another color and greys are all
the shades in between...”

Figure 5a)

Here is how the grayshades (above) map into the colors (below) in the Hue channel:

Figure 5b)

9. So, looking at the Hue channel we can guess that it will be red at the lower right, cyan in the middle etc.
and looking at the Saturation we can assume that there will be no color at the top, getting intense toward
bottom.



10. To see the results of the experiment, we need to reconvert: Goto Mode > RGB. This will take a few sec-
onds and build the complete 24-bit RGB image from the HSB channel data. Voila, instant colorizing:

Figure 6)  The completed RGB colorized image...

On an 8-bit card, you can also go one more step now from RGB to “Indexed” to see a better approximation..
Still nowhere near as subtle as the real thing. If you do this full  screen it is VERY smooth in 24-bit..

Look at figure 6) and read the summary in #10 one more time to see how the channels work together. Once
you really get this, it becomes a re-usable, predictable tool for you.
That is kind of the crux of all my chapters, the nirvana state of being able to conjure up any image or effect
and know all your tools to such an extent that you can create that image. (And then there are the happy sur-
prises while you’re on the way- kinda like life. Hmmmm.. Deep.)

Many of you have already dabbled with these things here or there, but to really KNOW what's going on is
another matter.

11. Ok, hit UNDO...and go back to the multi channel state. Let’s see what variety lurks here. ( if you did that
Indexed step UNDO will just bring back the RGB...you will need to then go back and separate to HSB again.
Caveat: This conversion is not lossless, as you can see in the Hue channel...)



I interject one of the other color dialogs not covered in chapter 12, the Image >Adjust > Curves...

Another very powerful one... For this example, simply click one the two points shown here and the curve will
snap around that immediately. You can also drag the points from the initial diagonal if you like...

Figure 7)  The Curves Dialog and two mouse clicks....

Figure 8)....get you this color splash! In big, this is REALLY splashy.



This redefines in a very complex way how the colors are spread and you end up with an incredible variety of
shades, hues, and neat little details. I hope you did this with the 400x300 size or larger to appreciate the
subtlety. Very nice. And if you move the points around or click-drag new ones, or do this in individual chan-
nels with different curves....you will see a bewildering array of color, all from that granite noise.

12. I realize you are not necessarily after a mind altering light show  (although I extend greetings to a mem-
ber of Pink Floyd here, who is not necessarily NOT after that..), but this ought to serve as a mere demo of
“process prowess”. It is implied that you can pull back to the toned down, gentle, plain or business-like color
schemes that fit the job in your particular case. (Wimp....)

Many of the filters have unexpectedly effective benefits when used after the splash stuff.

Figure 9a)

Figure 9 b) Filter > Stylize > Solarize and Emboss are very effective with such textures...



Hard to see in the tiny size, but do try them (and others)   Solarize will get very subtle paisley effects (Use
Adjust > Levels and Hue to get it just right) and Emboss (135, 1, 88 is a good setting) will create nice pitted
rough stucco wall textures. (Fade out more color and move the spectrum to get neat Santa Fe type back-
grounds )   Tip on Emboss, do a Blur before and a Sharpen after...

13. Well, the technique above inserted gradations into the Hue and Saturation channels to synthesize color
information. The more refined technique calls for  this information to be not random but related directly to
the original grayscale image. There are many ways to derive such information and I’ll glance over a few
here...

14. Lets say we have a grayscale image with some black shape on plain white background. I’ll use text
here, since that certainly happens a lot, but it could be just about anything.

Figure 10) Grayscale image ....

15. Use  Image > Calculate > Duplicate to create two copies of the original. I will do this with separate win-
dows to explain a further element in the colorizing trick bag, although you could also do it with multiple chan-
nels.

OK. The point is you can modify individual windows with any tools you like, but think of them in terms of pos-
sible use to define the Hue or Saturation, and later learn to have such ulterior motives with any image you
ever see. Wow. The mind wobbles.
16. In this example, to create a Hue definition we invert the original and Gaussian Blur it (3-ish) to create
more greyshades. Remember to now think of greyshades as different hues. Forget the edges or blurriness
they will be defined by the Brightness channel. That is 11 a)



17. For starters we do the exact same thing to create a saturation channel. In fact you can just duplicate 11
a) to get 11 b). Here it means something different though: the whitest areas in the center of the letter shape
will have the most intense color saturation, tapering off to the sides...

18. We take one of the originals and invert it, plus maybe one simple Blur to get 11 c). Interpreted as the
Brightness channel it simply means, where there is white we’ll see the color...

Figure 11 a)  Hue Figure 11 b)  Saturation Figure 11 c) Brightness

19. Now for the magic step: Go to  Mode > Merge Channels    (all the way at the bottom)  For Photoshop
2.5 and later, this is hiding in the popup menu in the channels palette. However, as described at the begin-
ning of the chapter, there is no HSL or HSB options. You do have Lab color mode though- all is not lost...

You will first encounter a selection of options, namely into which Mode to merge:

Figure 12)  The initial Merge Channels dialog



20. The number in the Channels box will tell you how many windows you currently have open that are mer-
gable (i.e. the same dimensions and grayscale... If the number is less than 3 or not what you expect check
that all the windows are indeed grayscale and identical size. Old tip > option-click (ctrl-click) on the number
next to the scroll bar in the bottom left of each window to get the size info)
Simply click on HSB, and the dialog continues:

Figure 13) The Merge Channels pop-ups for HSB

21. You will have to remember (or “think ahead of time” or “still see”) which window belongs into the HSB slot
and use the pop-up to assign them. On a big screen you can drag the windows often so you still see it, but
with larger files or a smaller screen you’d do better to think it through before you merge.

What exactly the pop-ups say will vary with how many windows you have open. E.g. it will very likely not be
6, 7 & 8 in your case...

Anyway, as soon as you click ok, the windows will disappear and a new one will pop up in the upper left
somewhere. You now have an HSB image and see one channel at a time. You can use Mode > Channel to
verify and look at each channel (command 1,2,3 (Ctrl 1,2,3,) as a short cut).



This is merely a different method to get to this stage. If all three are derivatives of one another you could
have used the Grayscale > RGB > HSB sequence just as well, but I wanted you to understand how the
Merge Channels command works and what to do with it. In fact, you may get one of the channels from
somewhere totally different and then you may need to do it this way...

Tip >>> you can obviously also merge three files into R, G and B and other such variations....

22. Anyway. Now use Mode > RGB and the three channels are interpreted as a single RGB 24-bit color
image  (again, in 8-bit you have the options to further convert to Indexed to see it better) and the color is
now following the shapes very nicely!

Figure 14)  The three images in fig 11 merged to HSB and then converted to RGB

23. What you need to understand here is that the color may not be what you want, or the intensity, or the
background...but all that is fixable!  This was meant only to colorize in a way that the color follows the shape
of the original. And as always in these chapters (or nearly) it did it algorithmically at any size or resolution. In
other words, I didn’t draw the little curves into the colors or used the smears or airbrush to do it. Not that I’m
against a painterly approach for those that are good at it or are looking for that effect. But this method is
much cleaner, especially across 15 letters in high resolution and also faster in general, accessible by that
vast majority that would have to call themselves less than proficient “artistes”. Finally there are numerous
effects that can not be easily handdrawn at all....



The effects change with scale (especially pixel oriented ones like Find Edges) so don’t worry if you don’t get
exactly this identical look. It doesn’t matter.

24.

Figure 15       a) Hue b) Saturation c) Brightness d) and RGB 24 bit image

Hue : Original letter, Blur once, Blend tool with “4” key down, lower right to upper left
Saturation: Blend tool, up, Blur More, Find Edges, Blur and Find Edges Again
Brightness: Inverted copy of Hue, one more blur and sharpen

25.

Figure 16      a) Hue b) Saturation c) Brightness d) and RGB 24 bit image



Hue : Noise 33, Crystallize 3, Blend 50% twice
Saturation: Blur More, Emboss 135,1,100, OverSharpen (Sharpen More 4 times)
Brightness: Blur, Emboss 135,1,100

26.

Figure 17     a) Hue  b) Saturation c) Brightness  d) and RGB 24 bit image

Hue : Gaussian Blur 3, Twirl 120
Saturation: Blur More twice, Find Edges, Invert
Brightness: Gaussian Blur 3, Arbitrary Map adding various sags and highlights, then smooth.

In fact, that last one about the Brightness channel brings me to the last dialog that adds color controls which
we haven’t discussed. We talked about Image > Adjust Hue/Saturation, Color Balance (in Colorization A),
Levels, Curves... the only one left is the Arbitrary Map.

There is a whole chapter on the Arbitrary Map/Curves dialog (8), but that’s focusing on other applications. It
also surfaces in the Moire Removal (chapter 10), but yet again for a special case. Here now a few more
basic Colorization ideas.



I suggest to load a colorized Spheroid image (see chapter 5) to do this, as it happens to contain multiple
continous tone colors which will demonstrate this effect very nicely.

27. What I’ve outlined so far works fine to go from grayscale to a flat color or range of colors. The following
allows you to add interesting spot colors, highlights, reflection effects, neon, metallics, etc. etc.
In fact the spheroid itself serves as the perfect example: I showed the technique in chapter 5 in grayscale
and then used a number of the Colorization methods on each sphere. (After each is created, the selection
marquee is still showing “marching ants” and all treatment will affect the local selection only. That's how you
get a blue and a red sphere)

With the spheroid on the screen, go to Image > Adjust > Curves... and in the dialog notice that in the color
mode new radio buttons let you switch from Red, Green, Blue and altogether in the Master channel. (These
are absent when you enter in grayscale).

Since I can only show the small blue sphere, I’ll mess with the blues (don’t worry, white boy ain’t gonna sing
none neither) and select the Blue channel. Now here are some basics you ought to be familiar with (great
additions to your arsenal). Do read #8 for more background though.

When you first enter, the ArbMap is a diagonal line as in figure 18 a)  in each of the 4 modes R,G,B, Master.
You can draw the opposite diagonal (figure 18b) to create the same effect as using Image > Map > Invert.

Figure 18) Normal Figure 19) Invert



28. Couple more basics: the adjustments are done in realtime with Direct Set Entries and this will affect  all
color on the screen at once. To see the final colors as they will actually come out, use Preview.

Old tip > On a 24-bit card you need to use Option-Preview (Ctrl-Preview)  to get the realtime mode back.
Clicking in the title bar (on the word “Arbitrary Map”- in versions of P.S. after 2.0, this will say “Curves”....)
will momentarily compare to the before settings, Option-Cancel (Ctrl-Cancel) will do a reset in all 4.
(“Reset” itself only resets R,G,B or Master.) If you use Load/Save add a prefix or suffix (“.arbmap”) since
there are lots of loadable files in PS. SuperBoomerang is nice for stuff like this, remembering the last
chronological list of files and graying out other formats)

Note also that the Smooth button works very well and plays a key role for gradual changes, but the corner
points are anchored! This means that all points except the first and last will be interpolated but those 2 stay
fixed where you happen to have drawn them! If you modified the last point to be at zero you can push
“Smooth” all you want and it will never get back to the normal diagonal.

I will first remove all blue entirely from the image and then look for interesting subsections to add back in.
Drawing “near the top” will add blue at full intensity, drawing ‘near the bottom’ will add near black. (Note:
this low = black assignment can be reversed by clicking on the little grayramp below the grid. This will mean
black is at the top. Other than psychological help, if you prefer to think of it one or the other way, I haven’t
found any deeper reasons to do this)

29. By drawing a quick line (doesn’t matter how wiggly it gets)  (my wife’s favorite line in this whole file)
near the bottom, all shades will be assigned an output value near black.
You can do it all the way down at zero, (the Eskimo’s wife’s favorite line), but then it looks just like a totally
empty dialog. You can use the shift-click method to draw straight vector lines...



Figure 20) The ArbMap/Curves dialog, blue channel selected and blue almost removed from the
image.



30. Note that the pencil is in the upper right corner. If you click a single pixel at 255, 255 you can then use
the Smooth button to go from “all black” to “normal” in about 10 steps. Kind of nice to see it build up almost
as an animation.

31. Here is a small part of the original Spheroids file. Read chapter 5 on the technique. It’s fun. Here now
you can see exactly how the additional reflections and refractions were added to the initially monochrome
image.

Figure 21 )  The medium size “Blendo Spheroid”.

This started as a grayscale spheroid and was colorized with you-know-what... Proof of the pudding.

32. Now one by one each channel can be modified, as seen in figure 21 a-d). The smooth curves in the
Green and Blue channel show up as alternate hues with gradations in figure 22)  The little dips in the Red
channel are “isolating” certain red bands on the sphere.



Figure 22     a) Master                b)   Red                 c)   Green                d)   Blue

Figure 23)  The modified sphere from fig 20)



Note: if you use discontinuous maps (as the red channel above) you are creating artificial aliasing errors and
jaggies. They need to be eliminated by other means (e.g. circle selection, then Selection > Border and blur
within that, or defringe, or others)
Load the arbmaps provided (includes the one in fig 21) and apply them to the whole Spheroid image. VERY
interesting effects!

To give you some incentive, here are just a couple more examples of what can be coaxed out of the plain
clean sphere... 23 a) is the “Ring of Fire” ArbMap, which emphasizes a narrow blue range to bring out those
“continentoids” on the black planet and a lava ring of fire around it... 23 b) is the “Flashed Lines” with an
entirely different globe and neat concentric circles in the shadow, as if photo-negative in a flash blast Both of
these look positively amazing over the entire Blendo image, as it affects each sphere differently.

The key to the ring of fire effect is to first predefine a smooth bell shape by drawing the crown and the two
bottom sides and hit Smooth once. The crown will come way down, since Smooth is a veritable Don Juan in
the smoothing department. This gives you the blended Aura. Then draw a new ‘hard’ crown line about 5-10
pixels wide, about 20 pixels above the crown. That extracts the extra bright line. A little tricky but worth mas-
tering...

Complex ArbMaps (provided!)  applied to a “Spheroid”:



Figure 24 a) Figure 24 b)

I hope you have a lot of fun with these methods and get to employ them some day. And if it’s only to walk up
to your neighbor Bob’s copy of Photoshop and say “betcha didn’t know THIS” and show him a thing or two
hundred.

Rule # 273  If you win bar bets over $10,000  I get a cut.

PS. I haven’t the foggiest how to get these beautifully printed on a black and white laser. Tell a friend if you
find these tips fruity, yet not overbearing, with a woodsy aftertaste.

Happy Photoshopping,     Kai Krause 


